BOX Outage
Incident Report for 14 West Product
Resolved
BOX is reporting that their services are fully operational again.

BUSINESS IMPACT

You should now be able to use BOX as you normally would.

For updates in real-time, you can check here at https://14west.statuspage.io/.

If you have any questions, concerns, or comments for the team, please email globalcommandcenter@14west.us.

Thank you,
Global Command Center
Posted Oct 19, 2020 - 15:16 EDT
Investigating
BOX has reported an outage that could affect users' ability to utilize the application. At this time, you may be unable to access BOX or experience performance issues when using the application. The team is monitoring the issue and will provide another update when we have more information or the issue is resolved.

For updates in real-time, you can check here at https://14west.statuspage.io/.

If you have any questions, concerns, or comments for the team, please email globalcommandcenter@14west.us.

Thank you,
Global Command Center
Posted Oct 19, 2020 - 10:54 EDT
This incident affected: IT (IT | General Operations).