IRIS Maintenance Messages
Incident Report for 14 West Product
Resolved
Some of you may have received inaccurate maintenance notifications via IRIS this afternoon. We are happy to inform you this issue is now resolved, during our initial investigation efforts we were able to identify that an unexpected complication of some scheduled maintenance earlier this week was responsible for the unexpected behavior.

For updates in real-time, you can check here at https://14west.statuspage.io/.

If you have any questions, concerns, or comments for the team, please email globalcommandcenter@14west.us.

Thank you,
Global Command Center
Posted Oct 21, 2020 - 13:59 EDT
Investigating
We are currently investigating reports of maintenance messages appearing when using IRIS. We are working to resolve the issue as quickly as possible and will provide an update when we have more information.

If you have any questions please contact us at GlobalCommandCenter@14West.US.

Thank you,
Global Command Center
Posted Oct 21, 2020 - 13:10 EDT
This incident affected: IRIS.