ADVISORY - Outlook Degraded Performance

Incident Report for 14 West Product

Identified

Microsoft is still working to fully restore Outlook service.
Posted Jul 10, 2025 - 12:36 EDT

Investigating

Is the ability to take or process orders affected?
No

Are Customers able to access their products?
Yes

The Issue
Some users are experiencing issues using Outlook. Reports have included new sign-ins to the Outlook client failing and with opening the Outlook web app (OWA) in Office 365.

The Impact
Existing Outlook client and OWA appear to be unaffected and not it appears to be happening to all users, although Microsoft's status shows degraded performance for Outlook in general. For more information see https://portal.office.com/servicestatus/

Workaround
If signing into the Outlook client is failing, its recommended to try the Outlook web app or vice versus. Also using a mail client on a mobile device may allow for successful logins.

Next Update
2 hours or as available.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Jul 10, 2025 - 09:19 EDT
This incident affects: IT (IT | General Operations).