Reporting Bug - eComm Summarized Stats

Incident Report for 14 West Product

Identified

We have identified a join issue between mailing stats and order stats where the Mailing Keys are exceeding the allowable character limit. If you are using eComm Analysis - By Mailing (Summarized), you can determine where this is occurring by selecting the attribute "Source System Mailing Key." If you see a "-" prefixing this value, the Mailing Key has exceeded the allowable limit and may be failing to accurately join mailing and order stats.

We suggest using the eComm Analysis - By Subscriber (Detail) for the time being if you are looking to tie mailing stats and order stats together until a fix is put into place.

All other IRIS related impacts should now be resolved.
Posted Dec 05, 2025 - 15:51 EST

Update

We are continuing to troubleshoot eComm Mailing Summarized data with new IRIS 2.0 promos. This has impacted some joins with IRIS 1.0 order data in Summarized data sets.

If you are looking at orders in Summarized Mailing data, please note orders may be misstated.

eComm Mailing by Subscriber is not affected.
Posted Nov 18, 2025 - 12:03 EST

Investigating

We are investigating an issue where stats are zeroing out in eComm Mailing Summarized data when evaluating IRIS 2.0 promo mailings. The issue occurs when adding mailing attributes to order attributes. eComm Mailing by Subscriber is not affected.
Posted Oct 24, 2025 - 11:02 EDT
This incident affects: Data & Analytics and Thoughtspot.