ADVISORY- Blueshift SSO Cert update
Incident Report for 14 West Product
Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 07:40 EST
Investigating
At 5:00 pm on Wednesday, November 20th, we will be updating the Blueshift SSO certificate.

We expect this to be a quick update, but you might experience a temporary error if you attempt to login while we are making this change.

Please note that any Blueshift users who are already logged in will not be affected.
Posted Nov 14, 2024 - 08:28 EST
This incident affected: Blueshift.