ADVISORY - Delay in Processing New Order CC Payments for the 5th of February 2024.
Incident Report for 14 West Product
Resolved
We are happy to report that as of 12pm EST, new order credit card payments are now fully caught up.

Impact Updates
The reason this occurred was due to a process configuration issue with our Advantage credit card process. Once we were made aware of the issue, we quickly corrected and immediately restarted the process. As mentioned above, all backlogged processing caught up by 12pm EST.

To prevent this from happening in the future, we have made the correction our default setting and the team has been made aware of the default setting moving forward.

Since we have monitored this morning and can see things are back to normal and fully caught up, we are going to mark this incident as Resolved.

Thank you,
14West Technologies Support
Posted Feb 06, 2024 - 14:20 EST
Investigating
Is the ability to take or process orders affected?
No

Are Customers able to access their products?
Yes

The Issue
Delay with processing of Credit Card Payments made on the 5th of February 2024 for New Orders.

The Impact
Transactions that were made and due to be processed on the 5th of February were not processed promptly and any due payments are now being processed.

Next Update
We will provide an update once all transactions have been processed and we have a better understanding of the scope.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Feb 06, 2024 - 10:55 EST
This incident affected: Advantage.