Advantage Order Processing Delays
Incident Report for 14 West Product
Resolved
Update

We have received confirmation from ACS that the issue experienced with processes not automatically rescheduling was due to the clock changes on Sunday.

Next Steps
Their Engineering team is working on a solution to prevent this from happening in the future.

In addition, we have adjusted our internal auditing to pick up this scenario in the future which will send a notification to the support team via our alerting system.

We will be closing this incident out now but if you have any further questions please do not hesitate to contact the Support Team.

Thank you,

14West Technologies Support
Posted Mar 12, 2024 - 12:17 EDT
Investigating
Is the ability to take or process orders affected?
At the time of the incident, Advantage Order Processing was impacted.

Are Customers able to access their products?
Yes

The Issue
We identified this morning that high-frequency Advantage order processes did not automatically reschedule on Sunday as they would normally. We suspect that this originated with the change in clocks on Sunday but we are still investigating this.

The Impact
Orders that hit Advantage on Sunday from around 2 am EST onwards were not processed until around 5:30 am EST today, Monday the 11th of March. All orders have now been processed and we have fully caught up. This will have a knock-on impact with delays in reporting.

Next Update
Once we have identified the cause of the processes not rescheduling we will provide an update.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Mar 11, 2024 - 10:19 EDT
This incident affected: Advantage.