IRIS Stats Recalculation Issue Following Maintenance

Incident Report for 14 West Product

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 15:01 EDT

Monitoring

The IRIS issue with Stats not calculating has been resolved.

Additionally any users who may have been experiencing errors trying to create efforts, or unable to find new creatives when setting up a tree is also resolved.

The database migration update needed time to process the queue, and that has now completed; therefore, any IRIS errors you may have been experiencing will now work as expected.

Thank you for your patience.
Posted Jul 09, 2025 - 12:21 EDT

Identified

Following scheduled IRIS maintenance earlier today, we’ve identified an issue with the stats recalculation process. As a result, some statistics in IRIS may currently appear lower than expected.

Our team is actively working to resolve this and restore full accuracy to IRIS stats as quickly as possible.

We’ll provide an update once the issue is fully resolved. Thank you for your patience.

The IRIS Team
Posted Jul 09, 2025 - 08:01 EDT
This incident affected: IRIS.