PayPal Payment Processing Issue with Soft Descriptors
Incident Report for 14 West Product
Resolved
Root Cause
We've traced the PayPal issue to a recent dynamic PayPal descriptor update by Paygate team, which has now been rolled back. We're logging descriptors instead of sending them to PayPal to stabilize payments.

Impact Updates
Four orders were affected during the issue. We're reaching out to impacted Affiliates.

Steps to Resolve
We've reverted the changes and are:
- Working on fix for PayPal dynamic descriptor functionality.
- Improving testing for payment updates.
- Enhancing monitoring for immediate issue detection.

Thank you,

14West Technologies Support
Posted Feb 07, 2024 - 13:03 EST
Investigating
Is the ability to take or process orders affected?
Yes.

Are Customers able to access their products?
Yes.

The Issue
We are currently experiencing a technical issue affecting PayPal payments on WMC, specifically tied to the processing of soft descriptors on publications. A subset of orders are not being processed as expected, resulting in an error message for users when attempting to finalize purchases using the PayPal payment method.

The Impact
Our team is presently investigating the true impact and severity of this incident. We are treating this as a priority.

Next Update
We will update you as soon as we have got a clearer understanding of the full impact but rest assured that we are treating this as a priority and will communicate ASAP.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Feb 07, 2024 - 10:12 EST
This incident affected: FinTech (PayGate) and WesTech Marketing Cloud.