ADVISORY - Microsoft Teams and Outlook Degraded Performance
Incident Report for 14 West Product
Resolved
Microsoft reports the issues with Teams and Outlook are now resolved.
Posted Jan 30, 2024 - 09:15 EST
Update
Microsoft reports that they are continuing to work to identify and remediate these issues.
Posted Jan 29, 2024 - 10:01 EST
Identified
Is the ability to take or process orders affected?
No

Are Customers able to access their products?
Yes

The Issue
Beginning January 26th 2024 10:37AM ET, users may be experiencing multiple issues with their Microsoft Teams and Outlook.


The Impact
For Teams:
Affected scenarios include, but aren't limited to:
- Users performing a cold boot may not able to log into teams and will see an "oops" page
- Users logging in or unlocking their devices after some time may see missing messages
- Users may fail to load messages in channels and chats
- Users are unable to view or download their media (images, videos, audio, call recordings, code snippets)
- Some messages may experience delays being sent
- Call Recordings might take longer to appear in user's OneDrive for Business and SharePoint Online
- Users may be unable to load previous Copilot history, or new history is not written
- Bots may be unable to download attachments
- Sending and receiving read receipt notifications may be delayed
- Anonymous users may be unable to join meetings
- Teams connectors for Power Automate/Power Apps may experiencing errors

For Outlook:
Some users may be unable to send or receive email messages, and receive an NDR with a 550 or 554 error code when sending.

Workaround
None

Next Update
Monday January 29, 2024 4PM ET.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Jan 26, 2024 - 16:45 EST
This incident affected: IT (IT | General Operations).