ADVISORY - PIE REST calls were impacted by brief Hasura API outage
Incident Report for 14 West Product
Resolved
According to our vendor, Hasura:
The incident started at Jan 4th 1:40 PM - 2:10PM EST.
During this time about 51% of requests were blocked on AWS and 52% were blocked on GCP.
We have resolved the issue.

14W will continue to monitor.
Posted Jan 04, 2024 - 14:37 EST
Monitoring
Is the ability to take or process orders affected?
No

Are Customers able to access their products?
Yes

The Issue
At approximately 1:56PM EST, PIE experienced an issue completing API calls via our provider, Hasura. The issue resulted in a HTTP Response Code of 429.

The Impact
Orders and Temp Orders were queued as a result, and resubmitted once PIE became available, at approximately 2:11PM EST. Pre-pop on order forms was most likely not available, but customers were still able to manually input their information.

Next Update
Hasura has reported an All-Clear, however, we will continue to monitor throughout the night.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Jan 04, 2024 - 14:31 EST
This incident affected: Platform Integration Engine (PIE) (Hasura REST API).