Advantage Launchpad Error

Incident Report for 14 West Product

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2026 - 05:04 EDT

Update

The issue affecting the Launchpad has now been resolved, and users can access the area again via OneLogin.

If you continue to experience any difficulties accessing the Launchpad, please submit a support ticket, and our team will be happy to assist you further.

For real-time updates, please visit https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Sep 21, 2026 - 05:02 EDT

Investigating

We are currently experiencing an issue accessing the Advantage application through the Launchpad.

The system is up and running in the background, and order processing continues as expected. However, users may be unable to access the Advantage user interface through the Launchpad.

As a temporary workaround, some users have been able to access the application directly using the following link:

https://advantage.14west.us/advantage-ui-PRODUCTION/v.2025.0.20319.2/

Our team is actively investigating the scope and severity of the incident and is treating this as a priority.

For real-time updates, please visit our status page:

https://14west.statuspage.io/

Thank you,

14West Technologies Support
Posted Sep 21, 2026 - 03:22 EDT
This incident affects: Advantage.