ADVISORY - Periods of Internet Access Loss in Baltimore Campus Buildings

Incident Report for 14 West Product

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2025 - 13:50 EDT

Investigating

Is the ability to take or process orders affected?
No

Are Customers able to access their products?
Yes

The Issue
We have experienced 2 periods of 2-5 minutes with a loss of Internet access on the Baltimore Campus. We are investigating the cause.

The Impact
This may impact your ability to connect to meetings or Internet applications

Next Update
We will send an update when we have more information.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Jul 22, 2025 - 11:35 EDT
This incident affects: IT (IT | General Operations).