ADVISORY - Potential Delivery Delays for SparkPost (Iterable) sent Emails

Incident Report for 14 West Product

Resolved

SparkPost deemed this incident resolved. All mail queues should be drained and all mail delivering as expected.

https://status.sparkpost.com/incidents/gz7xng93whxg
Posted Jul 24, 2026 - 14:49 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 24, 2026 - 12:33 EDT

Monitoring

All incident updates can be found here: https://status.sparkpost.com/incidents/gz7xng93whxg

Impact Updates
Campaigns sent using SparkPost (Iterable, NAC, IRIS) may see delays in delivery.

Steps to Resolve
At this time SparkPost is relying on AWS to fix the underlying issue. SparkPost is monitoring the mail queues and is still accepting all mail.

Thank you,

14West Technologies Support
Posted Jul 24, 2026 - 12:30 EDT
This incident affected: Deliverability.