NOTICE - PIE is Experiencing an Increase in Error Rates

Incident Report for 14 West Product

Resolved

The degraded PIE performance that occurred yesterday has been resolved, and we will continue to monitor the health of the application, as normal.

If you have further questions, or need additional assistance, please submit a support ticket to the PIE team: https://14west.atlassian.net/servicedesk/customer/portal/14/group/78/create/301

Thank you,
14West Technologies Support
Posted May 15, 2026 - 12:24 EDT

Monitoring

PIE is continuing to perform normally. We are continuing to monitor and will update if there is new information to share.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,
14West Technologies Support
Posted May 14, 2026 - 13:03 EDT

Update

We are seeing progress and PIE is back, seeing nominal errors, and performance is back to normal.

We are still identifying the root cause, and are continuing to monitor.

We will continue to update as we have further information to the root cause of this incident.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,
14West Technologies Support
Posted May 14, 2026 - 12:29 EDT

Update

We are continuing to identify the source of increased error traffic and are seeing drops and spikes in bad traffic.

We will continue to send updates every 30 minutes until resolution.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,
14West Technologies Support
Posted May 14, 2026 - 11:59 EDT

Update

We are seeing small improvements as we continue to narrow down the cause of this degraded performance.

We will continue to update every 30 minutes until resolved.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,
14West Technologies Support
Posted May 14, 2026 - 11:31 EDT

Update

We are continuing to investigate the cause of this issue. Performance remains degraded.

We will have another update by 11:30am Eastern.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,
14West Technologies Support
Posted May 14, 2026 - 10:59 EDT

Investigating

Is the ability to take or process orders affected?
No

Are Customers able to access their products?
Degraded performance and higher error rates

The Issue
There is an increase in the error rate in PIE which is impacting the Get All Data website login call

The Impact
All of PIE may be experiencing degraded performance. Website Logins are degraded and showing an increased error rate.

Next Update
As soon as we have further information from the vendor, we will update.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted May 14, 2026 - 10:27 EDT
This incident affected: Platform Integration Engine (PIE) (PIE Job API, ADV Rest Adapter, Hasura REST API).