Duplicate Tax Deduction on Gross & Net Revenue in IRIS

Incident Report for 14 West Product

Resolved

This incident has been resolved.
Posted May 22, 2025 - 09:14 EDT

Monitoring

We’ve resolved an issue that affects IRIS, where tax was being incorrectly deducted on gross & net revenue twice. The fix will be included in the Data Services regular release on Tuesday, May 20th.

No action is required on your end.

Thank you,
The IRIS Team
Posted May 19, 2025 - 09:21 EDT
This incident affected: IRIS.